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This document is based on information available at the time of its publication.  While efforts 

have been made to ensure the contents of this manual are accurate, the information 

contained herein does not purport to cover all specific details or variations in hardware, or 

to provide for every possible contingency in connection with installation, operation, or 

maintenance.  Features may be described herein which are not present in all hardware and 

software systems. Precision Valve and Automation, Inc.  assumes no obligation of notice to 

holders of this document with respect to changes subsequently made. 

Precision Valve and Automation, Inc. makes no representation or warranty, expressed, 

implied, or statutory with respect to, and assumes no responsibility for the accuracy, 

completeness, sufficiency, or usefulness of the information contained herein.  No warranties 

of merchantability or fitness for purpose shall apply. 

This document, including the information contained herein, is the property of 

Precision Valve and Automation, Inc. and is considered confidential and proprietary 

information.  It is delivered on the express condition that it not be used, disclosed, or 

reproduced, in whole or in part, for any reason without prior written consent of 

Precision Valve and Automation, Inc.  

 

Copyright © 2024 

Precision Valve and Automation, Inc. 

All Rights Reserved. 
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 Introduction 
Before you operate this system, read the operation and setup manual. This will help you to 
become familiar with the product and ensure successful operation. 

If any questions or problems arise, contact PVA’s Technical Support department. 

 

 PVA Contact Information 

Main Office   PVA  

   6 Corporate Drive  

   Halfmoon, NY 12065 

   Tel +1-518-371-2684 

   Fax +1-518-371-2688 

   Website: http://www.pva.net 

    Email: info@pva.net 

Technical Support  

Tel +1-844-734-0209 

   Email: cs@pva.net 

 

 Document History 

Revision Revision Date Reason for Changes 
REV D June 2024 Updated Download Instructions for Inkscape, G-code 
REV C April 2021 Maintenance Schedule Added 
REV B July 2020 Download Instructions for Inkscape, G-code 
REV A May 2020 Initial Release 

 

Note: All photographs and CAD model representations in this document are a 
“general representation” of the system and its components. The actual appearance 
of the system and its components can differ based upon customer specific 
configuration. 

 

http://www.pva.net/
mailto:info@pva.net
mailto:cs@pva.net
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 Safety 

Certain warning symbols are affixed to the machine and correspond to notations in this 
manual. Before operating the system, identify these warning labels and read the notices 
described below. Not all labels may be used on any specific system. 

 

Always wear approved safety glasses when you operate or work near the 
workcell. 

 

Before you operate the system, read and understand the manuals provided 
with the unit. 

 

Never put hands or tools in areas with this symbol when the machine is in 
operation. A dangerous condition may exist. 

 

Read and understand the manuals provided with the unit before any repairs 
or maintenance is done. Only a qualified individual should do service. 

 

Use caution when there are pressurized vessels. Find and repair any leaks 
immediately. Always wear appropriate safety equipment when you work 
with pressurized vessels or vessels that contain chemicals 

 

Shear hazard from moving parts. Avoid contact. 

 

Do not remove protective guarding. 

 

In situations where inattention could cause either personal injury or damage 
to equipment, a warning notice is used. 
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Do not smoke near the machine. Always have a fire extinguisher available 
for emergency use. 

 

Before performing any repairs or maintenance to the system, turn off power 
and lock out the power disconnect switch. 

 

Warning notices are used to emphasize that hazardous voltages, current, 
temperatures, or other conditions that could cause personal injury exist in 
this equipment or may be associated with its use. Only qualified personnel 
should enter areas designated with this symbol. 

 

Laser light source present. Do not stare directly into the beam. Do not use in 
the presence of highly reflective surfaces 

 

Pinch hazard from moving parts. Avoid contact. 

 

Hot surface. Avoid contact. 

 

Warning, Ultraviolet (UV) light hazard. Do not look directly at the UV light 
source. 
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 System Description  

The Sigma benchtop is a compact three-axis robotic gantry ideal for automating a variety 
of dispensing and coating applications. Featuring multiple mounting positions, users can 
easily incorporate multiple chemistries or application techniques into their process. With 
remote programming capability and image background import, programs can be quickly 
uploaded from your desktop utilizing Sigma’s internal 2.4 GHz Wi-Fi network. 

 

 Personal Protective Equipment 

Workcell operation includes air pressure, electrical power, mechanical devices, and the use 
of hazardous materials. Only qualified personnel can operate and service workcells. 
Operators must use eye protection because material contents are under pressure. Always 
wear gloves when handling materials and solvents. Refer to MSDS sheets on the material 
that is used for other precautions. 

 

 Best Practices 

• Do not wear loose clothes or jewelry when you operate the workcell 

• Do not touch the dispense head while it is moving  

• Make sure cables and pneumatics hoses are attached and do not cross walkways 

• Immediately engage the Emergency Stop button if personnel is in danger  

• Locate and define all safety labels on and around the workcell before you turn the 
machine “On” 

• There must be two people during maintenance procedures  

• Dispose of all used parts and materials in accordance with local laws and 
regulations 

• Safety is a joint responsibility between the OEM and the end-user. All precautions 
and practices should be in accordance with local regulations.  

DO NOT use incompatible tools, remove door interlocks or bypass safety devices, 
make custom mechanics or fluid delivery modification, or change material from the 
original design.  
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 Environmental 

Area of Possible Concern System Information  

Audible Noise Levels Below 65 dBA. 

Material and Chemicals There are no known dangerous materials or chemicals 
on this workcell. Refer to the MSDS sheet for the 
dispensed material.  

Hazards Due to Contact 

 

 

The workcell has safety features to minimize injuries. In 
some modes of operation it is possible to override 
safety features. Only qualified personnel should enter 
the work area when the workcell has power. All hot 
surfaces have a warning label. 

 

 Workcell Location 

The machine should be installed on a level surface away from standing water, possible 
overspray, and overhead leaks. 

 Handling, Transportation, and Storage 

The workcell should be handled and transported with minimal vibration and shock on the 
system. Use an air-ride truck for roadway transport. The machine is built for an industrial 
environment, but excessive abuse will decrease the performance of the machine.  

 

 Storage, Temperature, and Humidity 

When in storage, all enclosures and connector covers should be closed tightly. Put a cover 
over the system if there is dust or other airborne debris in the storage area. Store the 
workcell in an area that is 40F - 105F (4C – 41C) and low humidity. Do not let 
condensation collect on the machine. 

 

 Dispensing/Spraying Equipment 

When the workcell is stored for an extended period of time, it should be flushed with a 
solvent compatible with the application material and workcell components.  

Note: PVA is not responsible for damages incurred by incorrect transportation and 
handling of the workcell. The instructions given for the transportation, handling, and 
storage of the workcell are the correct manufacturer’s procedure.  
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 Installation and Setup 
Before you operate the workcell, know the components. Do the steps in this manual for 
safe and correct operation.  

Warning: Only qualified personnel should do these procedures. Obey this manual and 
all applicable safety regulations. A “qualified person” is defined as “a person or 
persons who, by possession of a recognized degree, certificate, or professional 
training, or who, by extensive knowledge, training, and experience, has successfully 
demonstrated the ability to solve problems relating to the subject matter and work.” 
(Ref. ANSI/ASME B30.2-1983.) 

 

 Uncrate and Inspect 

1. Use the Utility knife to cut the straps and the shrink wrap. 

2. Remove the cardboard as well as all packing materials and straps.  

3. Use a 9/16” wrench to remove the shipping bracket from the crate. Use a 3 mm hex 
key to remove the four shipping brackets. There are two on each side of the 
machine. 

 
 To Place the Dispense System 

1. Move the workcell to the necessary location. 

2. Loosen the lock nuts on each foot of the workcell, if necessary. 

3. Make sure that all four (feet) touch the ground. If any feet do not touch the ground, 
use the adjustable wrench to lower the feet by turning the feet clockwise. 

 

Figure 1: Adjust the Feet 

NOTE: When you lower the feet, you raise the workcell. When you raise the feet, you 
lower the workcell. 
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 Inspection 

1. Open the doors and remove all straps, tie wraps, and sponges around the dispense 
heads and gantry. In order to prevent any movement during the shipping process, 
many workcells are equipped with green shipping brackets inside the machine. The 
placement of these brackets will vary by workcell. The shipping brackets must be 
removed before continuing the inspection. 

2. Fully examine the workcell for damage, loose fasteners, etc.  

3. Use your hands to move the X and Y-axis slide to the center of the work area.  

4. Examine all tubing connections, gauges, and regulators. 

5. Open the electrical enclosure and visually inspect connectors and components for 
signs of vibration during shipping. Close the door, the machine should not operate 
with the doors open.  

6. Make sure all cables and connections are fully and correctly installed.  

 

 Level the Workcell 

This is the procedure to level the workcell. Put the level in the center of the jig plate. 

1. Look at the position of the bubble in the level window. The bubble will be centered 
between the two lines when the workcell is level. If the bubble is outside or closer to 
the right line, raise the left side of the workcell. If the bubble is outside or closer to 
the left line, raise the right side of the workcell.  

2. If necessary, loosen the locking nut on each foot with an adjustable wrench. 

3. Use an adjustable wrench to adjust the feet of the workcell. Put the wrench on the 
flat (unthreaded) part of the pedestal and turn in the necessary direction until the 
workcell is level from side to side. Turn the pedestal clockwise to raise the workcell 
and counterclockwise to lower the workcell.  

4. In each corner, put your hands on top of the workcell and push down. If one of the 
feet does not touch the ground the workcell will rock back and forth. Adjust the feet 
so that they all bear equal weight. 

5. When the workcell is level from front to back and side to side, is stable, and all four 
feet bear equal weight, use your hand to turn the locking nuts on the workcell feet 
counterclockwise until they are tight.  
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 Power Up  

After the accessories are installed, connect the workcell to air and power supplies. After 
the workcell is correctly connected, turn the main power switch “On” and make sure 
system components function correctly.  

WARNING: Failure to obey electrical specifications can damage the machine and 
injure personnel. Electrical hookup must be done by a qualified electrician and must 
comply with any applicable local standards. 

1. Plug the machine into an appropriate power source as shown on the legend plate on 
the right side of the machine. 

The electrical service must be correctly grounded and the power source “clean”. If high-
power equipment uses the same source, a line conditioner may be necessary. Poor power 
quality can cause machine errors. All workcells shipped from the PVA factory can operate 
with the voltage used at the installation site, per engineering design. 

WARNING: Make sure that the main power switch is “Off” before you connect the 
workcell to the facility power source.  

2. Find the main air regulator.  

3. Attach the workcell to the facility air supply. There is a ¼” NPT female fitting at the 
rear of the machine. Connect to a source of clean, dry air. A hose of ¼” inside 
diameter is sufficient. 

4. Slowly open the facility air valve. 

5. Close any access doors and engage in the Emergency Stop button.  

6. At the top of the machine, turn on the red air lockout valve. 

  

Figure 2:  Red Air Lockout Valve 
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7. Ground any pressure vessel to earth or the machine.  

8. Attach a correctly designed ventilation system to the exhaust port. It is necessary 
that the exhaust flow is correct for the specified CFM of your workcell.  

NOTE: Refer the Material Safety Data Sheets (MSDS) for safety precautions on any 
chemicals used in PVA equipment.  

NOTE:  Do not power on the workcell or add material to the pressure vessels until they 
are correctly grounded. 

9. Turn the main power switch “On”. 

 

Figure 3: Main Power Switch 

1. Perform the homing routine through the HMI.   

2. Manually jog to make sure there are no components that can be hit by the head in 
the work area.  

3. Make sure that the pneumatic and electrical cables do not decrease the heads travel 
and will not be cut or snagged when moved. Please contact Technical support if 
there are any problems. 

4. Make sure the valve and brackets are tight and that the valve does not rock or 
wiggle in the bracket.  

5. Close the doors. 
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 Necessary Downloads 

Prior to operating Sigma, please visit www.pva.net/sigma-setup to download a copy of 
the manual, Inkscape, and the PVA G-code Generator.  

1. Access www.pva.net/sigma-setup via browser. 

 

Figure 4: Sigma Download Website 

 

 Sigma Manual 

The Sigma manual will walk you through how to install and operate Sigma as well as how to 
use Inkscape and the web interface. Read this manual carefully prior to use.  

1. Click View Manual.  

 

Figure 5: View Manual 

2. From this screen, you can download, print, or copy link to share. 

http://www.pva.net/sigma-setup
http://www.pva.net/sigma-setup
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 Download Inkscape 

Sigma is designed to work exclusively with Inkscape version 0.92.4. Prior to use, Inkscape 
version 0.92.4 must be downloaded.  

1. Click Download Inkscape. 

 

Figure 6: Download Inkscape 1 

2. Follow the download prompts. 

 

Figure 7: Download Inkscape 2 

 

 

 



 
Sigma Operation Manual 

 

Revision D / June 2024 Page 18 of 70 

 

 Install PVA G-code Generator Extension 

Prior to use, the PVA G-code Generator extension must be installed within Inkscape.  

1. Click G-code Generator Extension.  

 

Figure 8: Download G-code Generator Extension 

2. You will be redirected to the Downloads page.  

3. Log in with your username and password or register as a new user.  

 

Figure 9: PVA Downloads Page 
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4. Once logged in, locate the PVA G-Code Generator Extension file and click 
Download. 

 

Figure 10: Download G-code Generator Extension 

5. The zip file will open in Windows Explorer.  

6. Select Extract All. 

 

Figure 11: Extract Files 
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7. Select the following Windows Explorer folder to extract the files: C:\Program 
Files\Inkscape\share\extensions 

 

Figure 12: Install PVA G-code Extension 2 
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 Operating Safety 
The workcell has several safety features that protect the operator from hazards in normal 
machine operation.  

Warning! The safety features should NEVER be bypassed, disabled, or tampered with. 
PVA is not responsible for any damage, mechanical or human, caused by changes or 
destruction of any safety features. 

 

 Safety Circuit 

The main power to the workcell is monitored and controlled by the safety circuit. The 
safety circuit contains two relays under-voltage protection and one or more safety 
devices. The relays are wired in a redundant manner. The tripping contacts of the relays 
are connected in series so the safety circuit will disconnect power even if one of the relays 
fails. The relays are self-checking with positive guided contacts electrically forced to 
operate together. If one redundant relays fails or a safety switch is activated, the power 
contacts are opened.  

 

 Polycarbonate and Safety Glass Guarding 

The work area is enclosed with either polycarbonate or safety glass guarding. The front of 
the workcell is either open, for the manual processing of parts, or has doors. 

 

 Doors 

The doors on the workcell are monitored during the dispense cycle. If the door is opened 
while the machine is in operation, this will trigger a pause on the machine.  

 

 Exhaust Fan 

The exhaust flange should be connected to a duct system that can receive the required* 
CFM (cubic feet per minute) while maintaining less than 1.0” H2O static pressure in the 
duct. If airflow through the exhaust system is not sufficient, it will generate an error. 
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 Standard Machine Exhaust Requirements 

Note: Check machine specifications. Custom order machines and processes may 
require higher exhaust flow rates. 

Note: Refer the Material Safety Data Sheets (MSDS) for safety precautions on any 
chemicals used in PVA equipment.  

Note: The safety devices on your workcell will be different with each model. 

 

 Notices and Warnings 

• You must wear safety glasses, gloves, and long sleeves 

• Lock-out and tag the air and power supplies before you service or clean any part of 
this equipment 

• Release the pressure before any hose (air or fluid) is removed 

• All hoses must have the correct pressure rating 

• Use only replacement parts recommended or supplied by the manufacturer 

• Stay away from all parts that move when the system is in operation 

 

 

 

 

 

 

 

 

 

Machine 
Exhaust 
Requirement 

Machine Duct 
Size 

Air Velocity at 
Test Point 
(ft/min) 

Air Velocity at 
Test Point 
(m/sec) 

Sigma 250 CFM 3” (76.2 mm) 4166 21.16 



 
Sigma Operation Manual 

 

Revision D / June 2024 Page 23 of 70 

 

 Inkscape 
Inkscape is an open-source vector graphics editor. PVA has created an extension designed 
to convert what is drawn in Inkscape to a G-code file that can be uploaded to Sigma. Sigma 
is designed to work with Inkscape version 0.92.4. Inkscape must be downloaded prior to 
use. Download instructions were included with Sigma. 

 Inkscape Manual 

This manual will cover the basic functions needed to create a dispense path in Inkscape as 
well as the PVA G-code Generator extension. For more information on how to use Inkscape, 
please refer to the Inkscape manual.  

 Accessing Inkscape Manual 

1. Select Help → Inkscape Manual. The Inkscape manual will open in your browser. 

 

Figure 13: Access Inkscape Manual 

 

 

Figure 14: Inkscape Manual 
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 Setup 

1. Once Inkscape is open, select File → Document Properties from the taskbar. 

 

Figure 15: Select Document Properties 

2. The Document Properties popup window will display. Under Custom Size, set the 
Sigma workspace dimensions (330 mm X 300 mm). 

 

Figure 16: Set Workspace Dimensions 

 

Note: If a template has already 
been created for the 
workspace dimensions, select 
New From Template. For more 
information, see the Open a 
Template section. 
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 Open a Template 

1. To open a pre-existing template, select File → New from Template.  

The New From Template window will open. 

 

Figure 17: New From Template 

2. Select the desired template from the list or use the search bar.  

3. Highlight to view the template details.  

4. Double-click the template or select Create From Template. 

The template will open as a new document.  

 

Figure 18: New Document from Template 
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 Create a New Layer 

1. Select Layer → Add Layer or Shift+Ctrl+N. 

2. Enter a Layer Name for the substrate and click Add. 

 

Figure 19: Add New Layer 

3. You can view and toggle between layers in the layer dropdown on the bottom left of 
the screen. 

 

Figure 20: Layer Dropdown 
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 Import Image (Optional) 

There is an option to import an image of the substrate as a reference for the dispense path. 
Ensure that the reference image is scaled correctly. Skip this section if it does not apply. 

1. Select File → Import or Ctrl+I and select the file to import. 

 

Figure 21: Import Image 

2. From the JPEG Bitmapp Image Import window, choose the Image Import Type, 
Image DPI, and Image Rendering Mode.  

3. Click OK to continue. 

 

Figure 22: Import Image 
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Note: There is also an option to paste the image onto the active layer. Simply use 
Ctrl+V to paste the image onto the workspace. 

The image will display in the workspace window and can be resized.  

 

Figure 23: Image Example 
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 Transform Image 

Resize the substrate image to its accurate size. 

1. Select the image. 

2. Select Object → Transform or Ctrl+Shift+M to open the Transform panel. This 
panel offers the ability to Move, Scale, Rotate, and Skew the image if necessary.  

 

Figure 24: Transform and Object Attributes 
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 Move Tab 

Use the Move tab to translate an object. An object can be moved horizontally or vertically. 
Use the arrows or enter a value manually in the field.  

An object will be translated relative to its current position if the Relative checkbox is 
selected. If the box is not checked, the lower-left corner of the objects bounding box will 
be moved to the given coordinate. 

 

Figure 25: Move Tab 

 

 Scale Tab 

Use the Scale tab to scale an object. An object will be scaled relative to the center of its 
bounding box.  

Use the dropdown to change the units and manually enter the correct size in millimeters. 
The Scale Proportionally option forces the width and height to scale by the same 
percentage. 

 

Figure 26: Scale Tab 
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 Rotate Tab 

Use the Rotate tab to rotate an object. An object will be rotated relative to Rotation center. 
The direction of the rotation is positive in the counterclockwise direction. 

 

Figure 27: Rotate Tab 

 Skew Tab 

Use the Skew tab to skew an object. An object can be skewed in horizontal and vertical 
directions separately. The skewing is relative to the center of the bounding box. The 
magnitude of the skew can be specified as a distance, percentage, or angle. In all cases, 
the skew is relative to the size of the bounding box. 

 

Figure 28: Skew Tab 

 
Note: Width Height, XY Position, and Rotation of the image can also be edited from 
the Tool Controls Bar. 

 

Figure 29: Tool Controls Bar 
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 Move Image 

There are three options to move the image to match its location on the workspace.  

Note: The X and Y coordinates will be the left-hand corner of the image.  

• Click and drag the image to its desired location. The position can be 
monitored by using the scale at the top in the Tool Controls bar or in the 
bottom right-hand corner in the Pointer Position window.  

• Manually enter the X and Y position in the Tool Controls bar.  

• Use the Move tab in the Transform panel.  

 

Figure 30: Move Image 
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 Lock Layer 

After the substrate image is resized and positioned in the desired location, PVA 
recommends locking the layer. There are two ways to lock a layer. 

• Select the image. Select Layer → Lock/Unlock Current Layer. 

• Select the image. In Layer Information at the bottom of the screen, select the layer 
that should be locked. Click the Lock icon to lock the layer. 

 

Figure 31: Lock Layer 
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 Create Dispense Path 

This section will review how to create a dispense path. It is recommended that each tool 
have a unique layer for its dispense path.  

Note: The robot will follow the dispense path based on the direction that a line was 
created. 

 Create a Line 

1. Once a new layer has been created, select  or Shift+F6 to select the Pen tool. 

2. Select the desired Mode from the Tool Controls bar . 

 Create regular path 

 Create Spiro path 

 
Create BSpline path 

 Create a sequence of straight line segments 

 Create a sequence of paraxial line segments 
 

Figure 32: Mode Options 

3. Click on the desired start point to begin the line. 

 

Figure 33: Starting Point 

 
4. Click a subsequent point along the line to add a control point (node).  
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5. Continue drawing additional segments if necessary. 

6. Hit Enter to complete the line or click on the first endpoint when placing the last 
endpoint. 

 

Figure 34: Completed Line 

 

 Edit a Line 

1. Use the Select tool and click the line that needs to be edited. 

2. To resize the line, click and drag the white arrows to scale. 

 

Figure 35: Resize Line 

 

3. Use the Arrow keys to move the last node created while drawing a path. 
Shift+Arrow moves the node by ten times the normal step,  

4. To delete the last node drawn, use the Backspace key or Delete key. 

5. To delete an unfinished path, use Esc or Ctrl+Z. 

6. To extend a previously drawn path, select the path, then click or click-drag on an 
end point. 
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 Create a Circle 

Circles are used to represent dispense dots. If a full circle is drawn, the center point of the 
circle is where the valve will dispense.  

1. Select the Circle tool .  

2. Click and hold at the start point of the circle. Drag to create the circle.  

 

Figure 36: Create Circle 

Note: To create a perfect circle, hold Ctrl as you click and drag the circle. 

 Edit a Circle 

1. Using the Select tool, click on the circle that needs to be edited. 

2. Use the arrows to resize the circle. 

3. To move the circle, click and drag the circle to a new location.  

 

Figure 37: Resize Circle 

 

 

 

 

 



 
Sigma Operation Manual 

 

Revision D / June 2024 Page 37 of 70 

 

 Create an Arc 

If an arc is drawn, the path will follow the start point of the arc to the end point.  

1. Use the Select tool to select the circle that should be changed to an arc. 

2. Once the circle is selected, select the Node Editing tool . 

3. Click and drag the white node to create a start and end point. 

 

Figure 38: Create Arc 

4. Select the Circle tool and the Switch to Arc command. 

 

 

Figure 39: Switch to Arc Command 
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 Edit an Arc 

1. Use the Select tool and select the arc that needs to be edited. 

2. To resize the arc, use the white arrows. 

 

Figure 40: Resize Arc 

3. To move the arc, click and drag. 

4. To edit the starting point, use the Node Editing tool. Click and drag the white circle 
to move the start and end points.  

 

Figure 41: Edit Arc Starting Points 

 

 Node Tool 

Dispense paths can be edited using the Node Tool. This flexible tool enables the addition, 
deletion, and movement of nodes. 

1. Select the Node Tool by clicking on the  icon. 

2. Select the object that needs to be edited. Once selected, the nodes will appear on 
the object. 

3. Use the icons in the Tool Controls bar to edit the node. See table on next page. 
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Insert new nodes into selected segments. Clicking on the path will select the 
nearest node on both sides of the point where the path was clicked. Double-
clicking on the path will also insert a node.  

 Delete selected nodes. 

 Join (merge) selected endnodes. 

 
Break path at selected nodes. Each selected node is converted into two end 
nodes. 

 Join selected endnodes with a new segment. 

 Delete segment between two non-endpoint nodes. 

Figure 42: Node Tool Icons 

 

 Set Fill and Stroke 

The fill and strike of lines, circles, and arcs can easily be edited for more visibility while you 
are working. There are four ways to change the fill and stroke: 

1. Select Object → Fill and Stroke. 

 

Figure 43: Fill and Stroke Option 1 
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2. Use Shift + Ctrl + F. 

 

Figure 44: Fill and Stroke Option 2 

 

3. Navigate to the fill and stroke area on the bottom left of the screen. 

 

Figure 45: Fill and Stroke Option 3 

4. Use the color toolbar on the bottom of the screen. 

 

Figure 46: Fill and Stroke Option 4 
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 Edit Path Order 

By default, the G-code will follow the order in which the dispense path was created. It will 
be generated from the upper most layer to the bottom layer. In the event that an 
application requires certain areas to be coated first or you need to reduce cycle time, the 
layers and path objects can be viewed and modified via the Objects window.  

Select an object or layer and use the icons below to arrange them in the desired order.  

 

Figure 47: Edit Path Order 

 
Collapse/Expand All 

 
Move to Top 

 
Move Up 

 
Move Down 

 
Move to Bottom 

  

Figure 48: Path Order Icons 
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 PVA G-code Generator 
The PVA G-code Generator is an extension that will create a G-code based on what is 
drawn in Inkscape.  

1. To open PVA G-code Generator, select Extensions → PVA → PVA G-code 
Generator.  

 

PVA Gcode Generator Window will display. 

 

Figure 49: PVA Gcode Generator 
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 Build Path 

The Build Path tab builds the G-code file. Each active layer will need layer settings and 
each selected object will need settings applied before the G-code file can be built.  

 

Figure 50: Build Path Tab 

 Dry Mode 

The Dry Mode option will remove the tool on commands from the G-code so the path can 
be run without opening the valve. This will allow the user to test the dispense path without 
dispensing any material.  

 Directory 

The Directory field is where the G-code file will be saved on the computer. There is no 
browse option; the address must be manually entered. Once a directory address is entered, 
it will be retained until it is changed. 

 File Name 

The Filename field is where the G-code file name will be entered. To add a numeric suffix to 
the filename, select the checkbox below. This will assign a new file number to the end of 
the filename each time a file is created.  
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 Layer Settings 

The Layer Settings tab applies the following settings to the selected layer. Any settings 
entered will not be applied until Apply is selected. 

 

Figure 51: Layer Settings 

 Action 

• Set Layer Settings: This action will apply settings to the active layer. 

• Display Layer Settings: This action will display all settings for the active layer in a 
text box.  

• Hide Layer Settings: This action will hide the text box settings for the active layer. 

• Import Layer Settings from Displayed: This action will load the settings from the 
active layer.  

 Viewing and Editing Layer Settings 

Prior to generating the G-code file, you can view layer settings to make any changes. 

1. Select the desired layer and select Extensions → PVA → PVA Gcode Generator. 

2. Navigate to Layer Settings. Under the Action dropdown, select Display Layer 
Settings.  

3. Perform this action for all layers that you would like to view settings for.  
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The Layer settings will display next to the workspace.  

4. Right-click to adjust the fill and stroke of the layer settings for visibility.  

 

Figure 52: Layer Settings Fill and Stroke 

5. To edit any of the layer settings, select the Text tool . 

6. Select the parameter that needs to be edited and make the necessary edit(s). 

 

Figure 53: Edit Layer Settings 

7. Open the PVA Gcode Generator and navigate to Layer Settings. 

8. Under the Action dropdown, select Import Layer Settings from Displayed.  

The Layer Settings will update. 

 
 Travel Speed 

Enter a Travel Speed that the robot will travel while it is not dispensing.  

 Safe Z Height 

After each dispense segment, the robot will move to a configured Safe Z Height before 
moving to the next dispense location. Enter a Safe Z Height for that layer.  



 
Sigma Operation Manual 

 

Revision D / June 2024 Page 46 of 70 

 

 Path Object Settings 

The Path Object settings applies the settings below to the selected path object(s). Leaving 
the ID Blank will apply the settings and leave the ID unchanged. 

Note: To select an object, the layer must be unlocked. 

  

Figure 54: Path Object Settings Tab 

 Unique ID 

Designates a specific name for the objects that are selected. 

 Tool 

Assigns a tool to the objects that are selected. If there are two tools on Sigma, the left tool 
is T0 and the right tool is T1. 

 Dispense Height 

Enter a Z height used for the selected objects i.e. if the circuit board is 5 mm and the 
desired dispense height is 2 mm, enter 7 mm.  
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 Line Specific Settings 

• Dispense Speed (mm): The dispense speed for the selected objects.  

• Valve Off Distance: The distance that the valve should be closed before the end of 
the selected line. 

• Valve On Time: The amount of time the valve will be opened before the dispense 
line starts. 

 

 Dot Specific Settings 

• Dispense Dot Time: The time in milliseconds that the valve will dispense onto the 
center point of the circle.   

• Post Dot Dwell: The time in milliseconds that the valve will wait after dispensing 
before it continues to the next dispense point.  
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 Operation 
 Generate G-code 

1. Once the G-code is ready to be generated, open the PVA Gcode Generator.  

2. Navigate to the Build Path tab. 

3. Enter the Directory information. 

4. Enter a File Name. 

5. Select Dry Mode and/or Enable Logging if necessary. 

6. Select Apply. The G-code will be saved in the designated directory folder. 

 

 Sigma Wireless Connection Setup 

Sigma has 2.4GHz wireless network connection capability that allows Sigma to be operated 
remotely with a computer. For the initial setup of Sigma, you will need to use this feature.  

 
1. Turn on Sigma using the on/off switch located near the power cord connection.  

2. The control screen will start up on its own.  

3. Connect to the network matching the serial number. The serial number is listed on 
the label located on the upper right corner of the back panel on Sigma.  

4. The network password is “PVA12345”.  

 

Figure 55: Sigma Serial Number Wi-Fi Network 
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5. Once connected to the network, access the computer interface by typing the 
machine IP address “11.22.33.44” into your Firefox or Chrome browser.  

The web interface will display.  

 

Figure 56: Sigma Web Interface Home Screen 
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 Connect Web Interface to Existing Network 

There is an option to connect an existing 2.4 GHz WiFi network to the web interface.  

Note: This option is not compatible with 5 GHz networks. 

1. Use the steps outlined in Sigma Wireless Connection Setup to connect to Sigma’s 
WiFi network. 

2. Once connected, access the web interface. 

3. Navigate to the G-Code Console.  

 

Figure 57: G-code Console 

 
 M587 Command 

The M587 command will be used to send your desired network information to the web 
interface’s G-code console. The M587 command must include three components. 

1. S: Network SSID 
• Must be enclosed in quotation marks 
• Case-sensitive 

2. P: Network Password 
• Must be enclosed in quotation marks 
• Case-sensitive 

3. I: IP address to use when connected to this network (optional). 
• If zero is entered or not specified, an IP address will be acquired via DHCP. 

The M587 command must be written in the following format: 

M587 S”WIFI_NETWORK_NAME” P”PASSWORD” Ix.xxx.xx.xxx 
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Example: 

Network SSID TEST_Network 
Network Password Testing123 
IP Address 1.160.10.240 

 

Using the credentials listed above, the M587 command would be as follows: 

M587 S”TEST_Network” P”Testing123” I1.160.10.240 

 

1. In the Send G-code field, enter the full M587 command. 

2. Click Send. A connection established message will appear. 

 

Figure 58: Enter M587 Command 

 

Additional Commands: 

• To view stored networks, enter M587 

• To see the current network connection and IP, enter M552 

• To remove the network from memory, enter M588 S”NETWORK_NAME” 

• To remove all networks from memory, enter M588 S”*” 
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 Change Web Interface to Client Mode 

1. To switch the web interface network from host mode to client mode, select 
Settings. 

2. Select System Editor. 

3. Navigate to the config.g file and right click. From the menu, select Edit. 

 

Figure 59: Access System Editor 

 
4. The file will open. Navigate to the Network section. 

5. To select a network, a semicolon must be placed in front of the network and 
removed from the other networks. 

 

Figure 60: Edit Config.g File 
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6. Delete the semicolon (;) from M552 S1. 

7. Add a semicolon (;) to M552 S2 to select the network.  

 

Figure 61: Change Network 

8. Click Save Changes. 

Note: The web interface must be rebooted after changes to the network have been 
made.  

9. Click Yes to reboot the web interface. 

 

Figure 62: Reboot Confirmation 

The web interface will confirm the file was successfully updated. 

 

Figure 63: File Updated 
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The control screen on Sigma will confirm that the machine is connected to the network. 

 
 
The network and IP address will appear on the control screen as the console tab of the web 
interface. The green popup will disappear after 10 seconds.  

 

 

Figure 64: Sigma Control Screen WiFi Confirmation 

 

Note: Sigma can also be powered down so the SD card storing the config.g file can be 
removed from the controller. Within the system file of the SD card is the Config.g file.  
This file can opened and modified with a program editor such as Notepad. 
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 Uploading G-code to Sigma 

1. Connect to the Sigma network using the directions from Sigma Wireless Connection 
Setup.  

2. From the Sigma web interface, select Upload & Start. 

3. Choose the desired G-code file. Once uploaded, Sigma will run the dispense path.  

More detailed information regarding how to use the Web Interface and Control 
Screen are provided in the next sections. 

 

 Web Interface Overview 

 Header Bar 

The Header bar allows you to view machine status, connect and disconnect the machine, 
quickly enter a G-code, upload a G-code to run, and stop the machine. 

 

Figure 65: Header Overview 

 Machine Control 

Machine Control allows you to home the X, Y, and Z axis and jog individual axis. You can 
also quickly run user-defined macros such as turning tools on and off, turning material 
pressure on and off, and deselecting tools. 

 

Figure 66: Machine Control Overview 
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 Job Status 

Job Status will display the progress of the current path. You can also change speed, pause 
the job, or start another job when the path is complete. 

 

Figure 67: Job Status Overview 

 

 G-code Console 

The G-Code Console provides a log of G-Codes entered, responses and errors, warnings, 
and notifications received since the browser was last refreshed. The console output can be 
downloaded as a plain text or CSV file. 

 
 G-code Files 

G-Code Files allows for G-code files to be uploaded, downloaded, deleted and sorted into 
sub directories.  

 

Figure 68: G-code Files 
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Files can be uploaded by browsing for them or dropping them onto the Upload G Code 
Files(s) button. The file upload functionality cannot be used during while the machine is 
running.  

 

Figure 69: Upload G-Code File 

 

Right-click on a G-code file to display a list of options. From here, you can run the dispense 
part (Print File), estimate the dispense path time (Simulate File), or download the G-code 
file (Download). You can also rename or delete the file, as well as manually edit the G-code.  

 

Figure 70: G-code Right Click Options 
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Figure 71: Edit G-Code 

 

 Macros 

Macros allows you to upload and edit user-defined macros.  

 

Figure 72: Macros 
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 Control Screen Overview 

The control screen on Sigma has the same features and functionality of the web interface.  
The two can be used interchangeably. 

 

Figure 73: Control Screen 

 

 
Select Tools 

 
Current Position 

 
Home All, Home X, Home Y, Home Z 

 
Access G-code Files 

 

Figure 74: Access G-code Files (Control) 
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Move Individual Axis 

 

 

Figure 75: Move Axis (Control) 

 
Access Macro Files 

 

Figure 76: Access Macro Files (Control) 

 

 
Control Screen (Current Screen) 
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Print Screen 

 

 

Figure 77: Print Screen 

 
G-code Console 

 
Quick Access Macros 
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 Maintenance 
Perform the preventative maintenance as shown in the table below to increase the life of 
the workcell and make sure every run is high quality.  
 
Note: Only qualified personnel should perform workcell maintenance.  

 
Service Area Every Shift Weekly Monthly Quarterly 
Dispense 
Equipment 

Examine all fluid 
pressures and 
dispense weights  

Clean material 
buildup on fixtures 
and locating 
surfaces. 
 
Examine for leaks 
around 
compression 
fittings, tighten or 
replace if 
necessary. 
 
Ensure all sealing 
packings are 
lubricated. Refer to 
individual 
component 
manuals for the 
procedure.  
 

Examine the fluid 
delivery lines for 
excessive wear. 
 

Examine the inline 
material filter for 
clogs  

Electro-
mechanical 
components  
 

 Examine the 
motors for 
overheating and 
smooth operation. 
 
Examine wires, 
pneumatic lines, 
and material lines 
for wear  

Ensure all belts are 
taught. 
 
 

Examine all moving 
cables for 
excessive wear. 
 
Lubricate all rails 
with a lithium 
based oil. 
 

Pneumatics    Examine for 
correct operation.  
 
Drain any water 
from the main 
filter/regulator  

Examine the slides 
for wear and 
smooth operation  

Clean Purge Cups  Daily     
Clean Valve Tips  Daily     
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 Technical Support  
 Calling Technical Support 

Technical Support is always available to help. The phone number is +1 (844) 734-0209 or 
you can email cs@pva.net to create a support ticket. Before you contact PVA, have the 
following information: 

1. Record all the information on the OIT when the error occurred, include any error 
messages that may appear. 

2. Record the operation in progress when the module had the error (when did it have 
problems, what was it doing, etc.). 

3. If the error was not serious, attempt to repeat the error. If the error does not repeat, 
the problem may have been operator generated. 

 

 Support Portal 

PVA uses an automated ticketing system called Team Support. The fastest way to contact 
PVA for any technical support is to create a ticket. The ticketing system alerts the service 
department of your region and assigns a service engineer. All service engineers can see 
the information for each ticket for collaborate responses to more difficult problems from 
our global team. Each problem and response can be tracked from creation to resolution. 
The Support Portal also has information on common issues and possible solutions. If 
immediate support is necessary, call your regional office (https://pva.net/contact). 

1. To access the ticketing system, click Support Portal located under the Support tab 
on the main menu. 

 

Figure 78: Support Portal 

 

mailto:cs@pva.net
https://pva.net/contact
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2. Select “Log In” to log in to your account or create a new one.  

 

Figure 79: Log In 

 

3. The Sign In screen will be shown. Fill in the information and select Sign In.  

4. To register, select Create an Account. Fill in the information and select Register 
Me. 

 

Figure 80: Sign In or Register 

5. When you are signed in, select Submit a Ticket from the header. 

 

Figure 81: Submit a Ticket 
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6. Fill in the information requested and use as much detail as possible. Include the 
equipment serial number and any screenshots, photos, or videos.  

7. Once complete, select Submit Ticket. 

 

Figure 82: Complete the Ticket 

 
8. If you cannot access the PVA Support Portal, email customer service at cs@PVA.net 

to create a ticket. To reply to a ticket email, select Reply (not Reply All).  

 

Figure 83: Example Ticket Email 

 

mailto:cs@PVA.net
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 Warranty 
PVA Warranty Policy                 

PVA warrants the enclosed product against defects in material or workmanship on all 
components for one year from the date of shipment. 

The warranty does not extend to components damaged due to misuse, negligence, or 
installation and operation that are not in accordance with the recommended factory 
instructions. Unauthorized repair or modification of the enclosed product, and/or the use of 
spare parts not directly obtained from PVA (or from factory authorized dealers) will void all 
warranties. 

All PVA warranties extend only to the original purchaser. Third party warranty claims will not 
be honored at any time. 

Prior to returning a product for a warranty claim, a return authorization must be obtained 
from PVA’s Technical Support department. Authorization will be issued either via the 
telephone, facsimile, or in writing upon your request. 

To qualify as a valid warranty claim, the defective product must be returned to the factory 
during the warranty period. Upon return, PVA will repair (or replace) all components found 
to be defective in material or workmanship. 

 

(Retain this for your records) 

 

Product Information: 

PRODUCT:      _____________________________________________ 

SERIAL NUMBER:     _____________________________________________ 

DATE OF PURCHASE:    __________________________________________________ 

 

 


